Chrome Extension is down.
Incident Report for CoSchedule
Resolved
This incident has been resolved.
Posted 10 months ago. Mar 16, 2016 - 14:53 CST
Identified
We've identified an error with our Chrome Extension, and have found a solution that will be live in less than 30 minutes.
Posted 10 months ago. Mar 16, 2016 - 14:05 CST