Increased load time
Incident Report for CoSchedule
Resolved
The incident has been resolved.
Posted 22 days ago. Aug 27, 2018 - 08:16 CDT
Identified
We've identified a few reports of increased load time, and are currently investigating.
Posted 27 days ago. Aug 22, 2018 - 10:24 CDT