Delayed email notifications
Incident Report for CoSchedule
Resolved
The issue has been resolved.
Posted 8 months ago. Jun 08, 2016 - 10:35 CST
Investigating
We are currently investigating a delay in some email notifications from CoSchedule. We will update when we have more information.
Posted 8 months ago. Jun 08, 2016 - 08:23 CST