Timezone issue affecting calendar items.
Incident Report for CoSchedule
Resolved
We've pushed a fix that resolved the time zone issue.
Posted over 2 years ago. Aug 14, 2015 - 08:40 CST
Investigating
We have identified an issue related to a timezone bug.
This does not affect all timezones, but some calendar items have had inconsistent date issues.

We are working on a resolution.
Posted over 2 years ago. Aug 12, 2015 - 11:01 CST