Live Chat not available
Incident Report for CoSchedule
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 09:15 CST
Monitoring
A fix has been implemented and chat should be available again.
Posted Nov 09, 2020 - 09:05 CST
Investigating
Our third-party vendor for live chat is currently investigating issues with the application - support chat on the website may not be available. In the meantime, please feel free to email us directly at support@coschedule.com.
Posted Nov 09, 2020 - 08:28 CST
This incident affected: CoSchedule App.