Billing and payment processing
Incident Report for CoSchedule
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 19:07 CDT
Update
We are continuing to experience increased latency with payment processing.
Posted Aug 31, 2021 - 15:34 CDT
Identified
We are currently experiencing an issue with our payment processing system.
Posted Aug 31, 2021 - 13:28 CDT
This incident affected: Web App.